Payment processing problems
Incident Report for Click & Drop
Resolved
This incident has been resolved.
Posted Sep 16, 2022 - 18:27 BST
Update
Parcel Collect has been re-enabled and we are continuing to monitor
Posted Sep 16, 2022 - 14:30 BST
Update
We are continuing to monitor for any further issues.
Posted Sep 16, 2022 - 13:21 BST
Monitoring
Our partners have mitigated the issue and we have reenabled postage purchases. Parcel Collect still remains unavailable.

We are continuing to monitor postage purchases closely
Posted Sep 16, 2022 - 13:21 BST
Investigating
We have seen issues with purchasing postage, preventing you being able to buy shipping labels using your debit/credit card or Paypal during this time.

If you generate your labels with a Royal Mail OBA account, you are not affected.

Other functions and features within Click & Drop will be unaffected.

We are working with our partners to get the issue identified and resolved.

We sincerely apologise for any inconvenience caused.
Posted Sep 16, 2022 - 10:06 BST
This incident affected: Website (Send an Item - send.royalmail.com, Click & Drop Payment Processing (Personal Customers), Royal Mail Mobile App - Buy and Send, Royal Mail Parcel Collect).