Issues purchasing labels
Incident Report for Click & Drop
Resolved
The issues affecting the purchase of postage have been identified and resolved.
Posted May 01, 2022 - 16:12 BST
Investigating
An issue at Royal Mail is impacting the purchase of postage for OLP customers. Our suppliers are currently investigating.

This does not affect OBA account users.
Posted May 01, 2022 - 15:01 BST
This incident affected: Website (Send an Item - send.royalmail.com, Click & Drop website (Registered), Royal Mail Mobile App - Buy and Send).