Issue with Squarespace APIs

Incident Report for Click & Drop

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 08:37 BST

Monitoring

Squarespace APIs are now available again and orders are importing
Posted Jul 31, 2025 - 17:36 BST

Identified

There is currently an issue with the Squarespace API preventing Click & Drop from connecting to their API.
We are waiting for an update from Squarespace on the issues with their API and will update this page with more updates as we get them
Posted Jul 31, 2025 - 10:36 BST
This incident affected: Integrations (Other integrations).