Some customers are reporting being unable to login, slow system response and/or errors
Incident Report for Click & Drop
Resolved
This incident has now been resolved
Posted May 29, 2024 - 16:11 BST
Monitoring
A fix has been implemented, the system is operational and we are monitoring. We apologise sincerely for any inconvenience caused.
Posted May 29, 2024 - 15:47 BST
Investigating
We are aware that some of you are experiencing slower system responses and occasional errors while using the Click and Drop application. Our technical team is actively investigating these issues to understand and resolve them quickly.

We understand how crucial our services are to your operations and are committed to ensuring a seamless experience. In the meantime, we ask for your patience and apologise for any inconvenience caused.
Posted May 29, 2024 - 15:01 BST
This incident affected: Website (Click & Drop website (Registered)).