Some customers are reporting slow system response and/or errors when using Click & Drop search

Incident Report for Click & Drop

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 11:11 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2026 - 10:20 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 27, 2026 - 10:18 BST

Investigating

We are aware that when using the Click and Drop search box in the top right of the screen, some of you are experiencing slower responses and occasional errors.
Our technical team is actively investigating these issues to understand and resolve them quickly.

You can still use the filter options in the grid to find your orders.

We understand how crucial our services are to your operations and are committed to ensuring a seamless experience. In the meantime, we ask for your patience and apologise for any inconvenience caused.
Posted Apr 27, 2026 - 09:54 BST
This incident affected: Website (Click & Drop website (Registered), Click & Drop Payment Processing (Personal Customers)).