Issues logging in to Click & Drop

Incident Report for Click & Drop

Resolved

Issue has been resolved
Posted Jul 19, 2025 - 12:49 BST

Update

We are continuing to monitor for any further issues.
Posted Jul 19, 2025 - 11:48 BST

Monitoring

The issue has been resolved and all users can now log in
Posted Jul 19, 2025 - 11:48 BST

Investigating

We are aware of some customers having issues logging into Click & Drop. The team are aware of this and are urgently investigating
Posted Jul 19, 2025 - 10:06 BST
This incident affected: Website (Click & Drop website (Registered)).