Issue affecting postage purchases via Card and PayPal
Incident Report for Click & Drop
Resolved
Continued monitoring overnight has shown no recurrence of the issue.
Posted Aug 01, 2022 - 08:34 BST
Monitoring
Our partners have advised that the systems are available again.
We will continue to monitor
Posted Jul 31, 2022 - 16:57 BST
Identified
We have identified an issue with another platform that is preventing the purchase of postage.
We have engaged with them and are awaiting an ETA on service restoration
Posted Jul 31, 2022 - 15:06 BST
Investigating
We've seen an increase in errors being reported when purchasing postage using card or PayPal

If you use Click & Drop with an OBA account, you are not affected by this issue
Posted Jul 31, 2022 - 14:29 BST
This incident affected: Website (Send an Item - send.royalmail.com, Click & Drop Payment Processing (Personal Customers), Royal Mail Mobile App - Buy and Send).