Some customers are reporting slow system response, problems downloading labels, logging in and/or errors
Incident Report for Click & Drop
Resolved
This incident has been resolved. Sincere apologies again for any inconvenience caused.
Posted Jun 04, 2024 - 16:07 BST
Monitoring
A fix has been implemented and we are monitoring system behaviour.
Posted Jun 04, 2024 - 12:49 BST
Investigating
We are aware that some of you are experiencing slower system responses, problems downloading labels, logging in and general errors while using the Click and Drop application. Our technical team is actively investigating these issues to understand and resolve them quickly.

We understand how crucial our services are to your operations and are committed to ensuring a seamless experience. In the meantime, we ask for your patience and apologise for any inconvenience caused.
Posted Jun 04, 2024 - 12:26 BST
This incident affected: Website (Click & Drop website (Registered)).