Some customers are reporting problems downloading labels
Incident Report for Click & Drop
Resolved
This incident has been resolved. Sincere apologies again for any inconvenience caused.
Posted Sep 03, 2024 - 16:53 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2024 - 16:21 BST
Investigating
We are aware that some of you are experiencing problems downloading labels, including labels not downloading and delays before labels successfully download. Our technical team is actively investigating these issues to understand and resolve them quickly.

We understand how crucial our services are to your operations and are committed to ensuring a seamless experience. In the meantime, we ask for your patience and apologise for any inconvenience caused.
Posted Sep 03, 2024 - 16:04 BST
This incident affected: Website (Click & Drop website (Registered)).