Issue affecting payments on Click & Drop
Incident Report for Click & Drop
Update
Following our Payment provider routing traffic to a secondary data centre, we continued monitoring payments, and no issues have been reported.
Posted Jun 14, 2022 - 08:23 BST
Monitoring
We are seeing successful payments processing and are continuing to monitor the situation
Posted Jun 13, 2022 - 17:15 BST
Investigating
We have been made aware of an issue with our payment provider, affecting postage purchases.
They are currently investigating.
We will update this page with any new information
If you have a Royal Mail OBA account, you are not affected by this issue.
Posted Jun 13, 2022 - 16:56 BST
This incident affects: Website (Send an Item - send.royalmail.com, Click & Drop Payment Processing (Personal Customers)).