All Systems Operational

About This Site

We monitor the status of the Click & Drop website and post any incidents here.

Website Operational
90 days ago
100.0 % uptime
Today
Send an Item - send.royalmail.com ? Operational
90 days ago
100.0 % uptime
Today
Click & Drop website (Registered) Operational
90 days ago
100.0 % uptime
Today
Click & Drop Payment Processing (Personal Customers) Operational
90 days ago
100.0 % uptime
Today
Click & Drop Manifesting (Business Customers) Operational
90 days ago
100.0 % uptime
Today
Royal Mail Print Assist ? Operational
90 days ago
100.0 % uptime
Today
Royal Mail Mobile App - Buy and Send ? Operational
90 days ago
100.0 % uptime
Today
Royal Mail Parcel Collect Operational
90 days ago
100.0 % uptime
Today
Integrations Operational
90 days ago
100.0 % uptime
Today
Amazon Operational
Click & Drop API Operational
90 days ago
100.0 % uptime
Today
Click & Drop Desktop Operational
Dropbox Operational
eBay Operational
Shopify Operational
Other integrations Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
Mar 28, 2024

No incidents reported today.

Mar 27, 2024

No incidents reported.

Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024

No incidents reported.

Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024
Resolved - This incident has been resolved.
Mar 18, 10:19 GMT
Monitoring - The OnBuy APIs have started responding again and orders are starting to import into C&D
Mar 18, 09:16 GMT
Investigating - OnBuy are currently having issues which is preventing orders from being imported into Click & Drop.
We have raised the issue with OnBuy and will update this page when we have a response

Mar 18, 08:49 GMT
Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.

Mar 14, 2024

No incidents reported.