Squarespace
Incident Report for Click & Drop
Resolved
Squarespace have marked their incident as resolved
Posted Nov 18, 2022 - 08:52 GMT
Monitoring
Squarespace are investigating an issue, you can check the status of the issue here https://status.squarespace.com
Posted Nov 17, 2022 - 23:09 GMT
Investigating
Squarespace API services (api.squarespace.com) are currently unavailable. As a result, Click & Drop cannot import orders from, or provide shipping updates to SquareSpace at this time.
Posted Nov 17, 2022 - 22:28 GMT
This incident affected: Integrations (Other integrations).