Some OBA users cannot create labels
Incident Report for Click & Drop
Resolved
This incident has been resolved.
Posted Aug 07, 2022 - 09:37 BST
Monitoring
Labels and Manifesting are now available again for OBA customers
Posted Aug 05, 2022 - 11:59 BST
Investigating
We are currently investigating an incident preventing some OBA users from generating postage labels. We apologise for the inconvenience and will update here as our investigation and resolution is progressed.
Posted Aug 05, 2022 - 11:47 BST
This incident affected: Website (Click & Drop website (Registered), Click & Drop Manifesting (Business Customers)).