Slowness & Difficulty Accessing Click & Drop
Incident Report for Click & Drop
Resolved
This incident has now been resolved, we will continue to monitor the situation.
Posted Nov 16, 2021 - 10:38 GMT
Update
We are continuing to investigate this issue.
Posted Nov 16, 2021 - 10:23 GMT
Investigating
We are investigating reports of slowness and difficulty accessing Click & Drop for some customers. We will update this page when we have more information.
Posted Nov 16, 2021 - 10:21 GMT
This incident affected: Website (Click & Drop website (Registered), Click & Drop Payment Processing (Personal Customers), Click & Drop Manifesting (Business Customers)).